Skip to main content

Environmental Requirement

...Less than 1 minute

Environmental Requirement

To use IoTDB, you need to have:

  • Java >= 1.8 (1.8, 11 to 17 have been verified. Please make sure the environment path has been set.)
  • Maven >= 3.6 (if you want to install IoTDB by compiling the source code)
  • Set the max open files num as 65535 to avoid "too many open files" problem.
  • (Optional) Set the somaxconn as 65535 to avoid "connection reset" error when the system is under high load.

# Linux
sudo sysctl -w net.core.somaxconn=65535
# FreeBSD 或 Darwin
sudo sysctl -w kern.ipc.somaxconn=65535

Copyright © 2024 The Apache Software Foundation.
Apache and the Apache feather logo are trademarks of The Apache Software Foundation

Have a question? Connect with us on QQ, WeChat, or Slack. Join the community now.